Distribution of SUSE Linux Enterprise 15 SP6 now accessible

After a year of development, SUSE presented release of the SUSE Linux Enterprise 15 SP6 distribution. Based platforms SUSE Linux Enterprise has formed such products as SUSE Linux Enterprise Server, SUSE Linux Enterprise Desktop, SUSE Linux Enterprise High Performance Computing and SUSE Linux Enterprise High Availability Extension. The distribution can be download and is free to use, but access to updates and patches is limited to a 60-day trial period. The release is available in builds for the aarch64, ppc64le, s390x and x86_64 architectures.

SUSE Linux Enterprise 15 SP6 supports full binary package compatibility with the community-developed openSUSE Leap 15.6 distribution, which was released last week. A high level of compatibility is achieved by using openSUSE to use a single set of binary packages with SUSE Linux Enterprise, instead of rebuilding src packages. It is expected that users can first build and test a working solution using openSUSE, and then seamlessly switch to a commercial version of SUSE Linux with full support, SLA, certification, long-term update releases and advanced tools for mass adoption.

Advertisement

Basic changes:

  • The desktop environment has been updated to GNOME 45 (previous release was GNOME 41). The graphics stack has been updated to Mesa 23.3.4.
  • The Linux kernel has been updated to version 6.4 (the previous release used the 5.14 kernel). In the system environment, glibc 2.38 and systemd 254 have been updated. Systemd uses cgroup v2 by default.
  • Updated packages dracut 059, PulseAudio 17.0, PipeWire 1.0.4, DPDK 22.1, OpenSSL 3.1.4, firewalld 2.0.1, GnuTLS 3.8.0, OpenVPN 2.6, MariaDB 10.11.6, PostgreSQL 16, Redis 7.2, PHP 8.2, Node. js 20, BIND 9.18, OpenSSH 9.6p1.
  • Updated components used for virtualization and container isolation: Podman 4.8.3, Xen 4.18, KVM 8.1.3, QEMU 8.2, libvirt 10, virt-manager 4.1, Open vSwitch 3.1, OVN 23.03, Docker 24.0, containerd 1.7.10, Skopeo 1.12, open-vm-tools 12.3.5.
  • Added experimental iaa (IAA Compression Accelerator) driver to speed up data compression and decompression using the capabilities of Intel Analytics Accelerator (IAA) cryptographic accelerators.
  • By default, the use of the Docker Hub and openSUSE Registry container repositories is disabled; to load containers from these repositories, you must specify them in the /etc/containers/registries.conf file.
  • Added sysctl-logger package, which uses BPF to monitor changes in sysctl values.
  • Added the rpm-imaevmsign package with a plugin for the RPM package manager, allowing the use of IMA (Integrity Measurement Architecture) and EVM (Extended Verification Module) technologies. IMA is used to verify the integrity of operating system components using digital signatures and hashes. EVM allows you to protect extended file attributes (xattrs) from attacks aimed at violating their integrity.
  • X.org and Xwayland servers do not accept connections from clients with other hardware architectures by default.
  • NFSv4 implements IPv6 support on the client side (NFSv4 server does not support IPv6).
  • OpenSSH does not allow the use of RSA host keys smaller than 2048 bits.
  • In the installer, reuse of existing LVM partitions is disabled by default.
  • The installer in the YaST Partitioner partition editor supports disk encryption using the LUKS2 (Linux Unified Key Setup) format.
  • Added support for NVIDIA Virtual GPU (vGPU) 16.2.
  • The numad, openmpi2 and openmpi3 packages have been removed. Due to security issues, the dpt_i2o driver for Adaptec I2O-based RAID controllers has been removed.

Thanks for reading:

Advertisement